July 6, 2020

We're back! Thank you for your patience during the move.


PLEASE READ (click)

ABS dummy light on problem and diagnostic method

FROM STOCK TO WILD, BRAKE ISSUES AND UPGRADES GO HERE.

Moderator: leadtrombone

User avatar
blk lt awd
I sleep in my van
Posts: 346
Joined: Tue Sep 26, 2006 5:09 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: VANcouver
Contact:

Re: ABS dummy light on problem and diagnostic method

Post by blk lt awd » Sun Apr 07, 2013 1:40 am

nog00der wrote:theres guys that can fix this for around $60. its just a matter of soldering a few contacts in the unit itself. the hardest part is getting it off of the van, its held in place by 4 #20 torx screws. you can find youtube how to videos on the soldering points if you want to try and do it yourself.
Do you have a link by any chance?
1995 Black LT AWD
2000 Ninja ZX-6R
2003 Mazdaspeed Protege (spicy)
1961 Impala...gone but not forgotten.

http://www.propertystation.ca/

JimY
I am merely driving my van
I am merely driving my van
Posts: 2
Joined: Tue Mar 06, 2018 1:11 am
antispam: No
How many wheels are on an Astro van? (4): 4

Re: ABS dummy light on problem and diagnostic method

Post by JimY » Mon Mar 19, 2018 1:28 am

I’m new here and have recently acquired a 2000 Astro.

Just wanted to confirm the various posts here regarding abs light and brake light coming on.

My story - I flushed brakes and installed new drums, shoes, cylinders, front wheel bearings, and front pads. After doing this work I noticed the abs and brake light would come on after a few minutes of driving - often after hitting a bump in the road.

So I gravity bled the brakes to verify proportioning valve want stuck. It wasn’t. So I found the harness for the speed sensor and metered it with a friends meter (which was on auto, and defaulted to “DC mV.” After getting only about 0.8 mV DC (I figured it would auto shift to AC if volts present) I figured bad sensor(s). So I replaced the front wheel sensor. Lights came on just as before.

Now thoroughly mad I figured I’d use another meter and Lo and behold it had about 1V AC when spinning. So then I moved on. The only ground I could find that went to ABS on my 2000 Astro RWD was up near the radiator and it was good. So, after much stalling and trepidation I decided to remove EBCM and Check solder joints. wheeeew that sucks to do. Took me about half a day or so from start to finish. Only one solder joint (as described elsewhere on this forum) was questionable - but actually it looked fairly good. Nevertheless I re-soldered the terminals recommended, reinstalled, and started it up. After driving for much longer than it would usually show the abs and brake light - it did not. So I decided to go fast and slam on the brakes. ABS kicked in. YES!

I did get a scan tool that reads ABS codes and it was reading C0265 - relay coil ABS - on my “BlueDriver” scanner.

Anyways, wanted to leave my experience so that someone may benefit from my long struggle.

Many thanks to those who shared their fixes for this elusive problem!

Jamack513
I am merely driving my van
I am merely driving my van
Posts: 2
Joined: Thu Apr 23, 2020 4:29 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: ABS dummy light on problem and diagnostic method

Post by Jamack513 » Wed Jul 01, 2020 8:16 pm

I know this is an old post, but I didn't want to start a new one b/c I sort of have the same issue. Except, I think it may be something else. I've had a lot of issues with this safari. But my latest is the ABS light and brake light. They randomly came on the other day, but it also affected the way the engine is running. I barely thought I was going to make it home. I did and checked all of the wires on the Battery, they were fine. I have been thinking I have a short somewhere, b/c it seems weird that the EBCM would affect the engine running, am I wrong? That was 2 days ago. Yesterday I started her up just to check, the Brake light was off but ABS light was still on. I pressed the brakes and the engine shut off, it was in park. I have been looking at ways to check a short and will start on that tomorrow. But I figured I would ask...
Thanks,
J

User avatar
timelessbeing
Site Admin
Site Admin
Posts: 2741
Joined: Fri Aug 08, 2008 7:55 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: ABS dummy light on problem and diagnostic method

Post by timelessbeing » Thu Jul 02, 2020 4:32 am

If you want to get the problem solved quick, your best bet is to take the van to someone with an ABS scan tool. Otherwise it might be a bit of a guessing game.

The wheel speed sensors are kind of a problem spot on these vans and that could be setting your light. They get caked in rust and stuff and start giving bad signals, and sometimes even premature ABS activation which can lead to dangerous situations! :yikes: You can give them a clean, and measure with a meter to make sure they're within spec. I'm sure you'll find the exact details either somewhere on this forum or with a web search.

Jamack513
I am merely driving my van
I am merely driving my van
Posts: 2
Joined: Thu Apr 23, 2020 4:29 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: ABS dummy light on problem and diagnostic method

Post by Jamack513 » Fri Jul 17, 2020 12:50 pm

OK, So I found an EBCM and Solenoid motor from a Blazer that is exactly same as the 2003 Safari. Changed it out, added new rear brake line, PITA, and bleed the system. ABS light did come back on and the motor ran like crap. Check engine light came on, motor sputtered, etc. Bought a OBDII/ABS scanner (local shop charges $50 minimum just to read the computer and no auto parts store uses a scan tool with ABS). I didn't write the codes down since they could have been stored from the last EBCM. the Stored codes were TPS and EBCM. I cleared them and took the safari around the neighborhood. all was fine until I hit a bump. Engine completely shut down. car was in Drive but the light showed it was in Park??? weird. Made a stop, put in park and restarted. ABS light is on but no Codes are showing in scanner. I will check the Wheel speed sensors, but if they were the issues should they not show up in the scan tool? This morning hooked up the Scan tool, I need to read up more on how to use this tool as it is a bit more complicated than my simple OBDII. However, no ABS or Check engine light illuminated. Took her around the block again and did the exact same route as yesterday. hit the same bump and the engine completely went dead. Put in park and started right back up. it's an alley way and lots of pot holes. every time I bounced, engine ran rough and so I purposefully hit a large bump again and the engine completely shut off. Put in park, started up again and got home. No lights illuminated on the dash. things that make you go HMMM... :-$

User avatar
timelessbeing
Site Admin
Site Admin
Posts: 2741
Joined: Fri Aug 08, 2008 7:55 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: ABS dummy light on problem and diagnostic method

Post by timelessbeing » Fri Jul 17, 2020 9:03 pm

That sounds like a loose electrical connection somewhere.

Captn. Crunch
Site Admin
Site Admin
Posts: 544
Joined: Wed Feb 01, 2012 8:10 pm
antispam: No
How many wheels are on an Astro van? (4): 4
Location: southeastern ct

Re: ABS dummy light on problem and diagnostic method

Post by Captn. Crunch » Sat Jul 18, 2020 12:36 am

Timeless is probably right with the loose wiring connection. Two quick things you can do to start.
A bad ground wire can cause all kinds of symptoms. Follow the negative battery cable to where it attaches to the body. Start the engine and touch the head of the bolt holding the negative cable to the body. If it gets warm/hot it’s a bad ground. Pull it, wire brush it. Actually do that irregardless
The ignition switches wear out. Go for another ride around the Block. Hit a bump while holding the key firmly in the ignition. See if that makes a difference.
Good luck
Captn. Crunch
"I don't beat my rig-I use it to it's maximum potential"
1994 Safari conversion (sold) and miss'n it!
1999 Safari SLE AWD junked
2003 GMC Safari AWD SLT
cast iron Torsen equipped front diff
S-10 leafs-G80 rear w/3.73’s
2” body lift w/Falken Wildpeak AT’s

Post Reply