Electrical gremlins

USE THIS FORUM FOR ANY ELECTRICAL QUESTIONS SUCH AS WIRE COLOR CODES, BLOWING FUSES OR WIRING SHORTS.

Moderator: v8famvan

Post Reply
astrojohn
I am smitten with my van
Posts: 38
Joined: Sat Oct 08, 2011 10:57 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Electrical gremlins

Post by astrojohn » Wed May 18, 2016 1:30 am

I have a 2002 Astro AWD. Love the darn thing, but a couple gremlins have popped up, and am having a hard time figuring them out.
#1 My air condition compressor, won't kick on. I have checked for Freon, and its charged up. I've checked fuses, and they are all good. I checked the relays, even switched them around, and they are working. I even jumpered across the low pressure switch, and it won't kick on. I have continuity to the ground wire at the compressor, but not 12 volts to the positive side. The only thing I haven't checked, is the high pressure switch, behind the compressor. Am I missing something, say like a cycling switch? If so, where is it located.
#2 While playing with the AC problem, I had replaced the center door rollers, for the side door, as mine were bad. This is all I did, but since I changed it, I'm having trouble with my door locks. They keep cycling, and once in a while, the dome light flickers on with the locks. I started paying attention to what is going on. I can hear a relay or something, under the dash when this goes on, even when the dome lights flicker. The side door lock, was making the most noise, so I put duct tape over the contact points at the post, so that the lock motor, wouldn't keep cycling. Now my front door locks won't electrically lock. Not enough oomph. The rear hatch lock works fine.
So what do I need to do, or replace? Lock switches, Lock motors, or something else that activates the locks.
Sure hope someone can help me with both of these problems. A thank you to anyone who can help me fix these Gremlins :axe:

astrojohn
I am smitten with my van
Posts: 38
Joined: Sat Oct 08, 2011 10:57 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: Electrical gremlins

Post by astrojohn » Sat May 21, 2016 12:38 pm

Well, I have figured out both my problems. First, with the door locks. As I had nothing better to do, I went through all the pages, and found someone, who had the same problem as me. And, as I noticed, the dome light switch, on the sliding door, was broken off. I replaced that, and everything started working again. I did have to replace the driver door, lock switch, as it must have taken a beating from the constant activation, from the faulty light switch.
The second problem, I had to dig a bit farther. I was at a local salvage yard, and being that there was an Astro there, so I opened up the wiring harness, and followed the green wire from the ac compressor, to up to the fuse box. I had a schematic of the wires, path, but I was skeptical. I started doing relay checks, to be sure it was working entirely. I found, that the ac enable relay was not kicking in, but when I bench tested the relay, it worked. So I'm back to checking fuses. They were all good. The only other place power would turn the relay on, is at the Dash control switch. Found the problem. So, I ordered a HVAC switch on line, and will install when I receive it. I'm betting it will work.

Post Reply