How to wire up a NP 236 in place of a 136.

FROM AWD'S TO 2-SPEED MANUAL SHIFT, IF IT LINKS THE REAR AXLE TO THE FRONT AXLE, POST IT HERE.

Moderator: Cobra

Post Reply
racrx7
I finally get the smurf thing
Posts: 134
Joined: Sun Jul 26, 2015 8:25 pm
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Charleston SC

Re: How to wire up a NP 236 in place of a 136.

Post by racrx7 » Thu Jun 08, 2017 6:41 am

BTW, do you have two connectors, blue and green on yours? You seem to be saying ours are the same. I think the source of the confusion may be this diagram you posted earlier. On the right side it shows a "Vehicle Control Module" and pin 23 on Connector 4...
WOW!!! How did I miss that??!! That diagram is for the older PCM's, which I guess were called "VCM's", that used the older style 4 connectors instead of our two connector 80pin setups.
And yes, I have the blue and green connectors on my '03. SOOOOOO, you'll connect F7-C1 from the TCCM TO pin #16-C2 connector on your PCM.

My apologies for this oversight :dunce: I will have to see if I can find the correct Schematic and do an update. If you can find it on ESI that you are downloading, maybe you can share it?

Good catch on my booboo!! :cheers:
O3 Astro 4X4
Image
Dropped front IFS axle
Journeys rear spring hangers and shackles, S-10 leaf springs, 2" body lift
255/70-16 BFG KO2's on 16x8 Fuel Revolvers

curtperry
I am merely driving my van
I am merely driving my van
Posts: 7
Joined: Tue Jun 06, 2017 3:55 pm
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Eastern Washington

Re: How to wire up a NP 236 in place of a 136.

Post by curtperry » Sat Jun 10, 2017 7:24 am

racrx7 wrote:WOW!!! How did I miss that??!! That diagram is for the older PCM's, which I guess were called "VCM's", that used the older style 4 connectors instead of our two connector 80pin setups.
And yes, I have the blue and green connectors on my '03. SOOOOOO, you'll connect F7-C1 from the TCCM TO pin #16-C2 connector on your PCM.

My apologies for this oversight :dunce: I will have to see if I can find the correct Schematic and do an update. If you can find it on ESI that you are downloading, maybe you can share it?

Good catch on my booboo!! :cheers:
You, sir, have no need to apologize. I can't thank you enough for this awesome info.

Unfortunately the torrent download for the GM ESI stalled due to lack of seeders, can't find dvd on ebay either. Ah well, we know what goes where... we don't necessarily need a picture.
2005 Astro 4x4, 4-5" lift, 31" Tires, np236 Transfer Case, Trans-Go Shift Kit, Hayden Tranny Cooler, Ultragauge MX

Astrophysics
I sleep in my van
Posts: 825
Joined: Sun Jan 13, 2008 5:23 am
antispam: No
How many wheels are on an Astro van? (4): 4

Re: How to wire up a NP 236 in place of a 136.

Post by Astrophysics » Sun Jun 11, 2017 10:22 pm

Hi Everyone,

Wow, the np236 looks like the way to go.
I have 2003 Astro AWD with 2" lift.
I have a np233 that I was going to install to get low range.'maybe I will go the pic n pull to get np236.

AP

curtperry
I am merely driving my van
I am merely driving my van
Posts: 7
Joined: Tue Jun 06, 2017 3:55 pm
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Eastern Washington

Re: How to wire up a NP 236 in place of a 136.

Post by curtperry » Wed Jun 14, 2017 7:10 am

racrx7 wrote:If you can find it on ESI that you are downloading, maybe you can share it?
It downloaded after all...

Here's the schematic for a 2005 Blazer with NV236... It appears to have the same connectors on the PCM as we do and again confirms Pin 16 on Connector 2 (Green)
Attachments
05Blazer_TCCM_to_Axle_and PCM.jpg
2005 Astro 4x4, 4-5" lift, 31" Tires, np236 Transfer Case, Trans-Go Shift Kit, Hayden Tranny Cooler, Ultragauge MX

curtperry
I am merely driving my van
I am merely driving my van
Posts: 7
Joined: Tue Jun 06, 2017 3:55 pm
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Eastern Washington

Re: How to wire up a NP 236 in place of a 136.

Post by curtperry » Wed Jun 14, 2017 7:41 am

I am totally geeking out over this ESI info.

The 4wd Lo signal to the PCM:

2005-2003 are 2 connectors, blue and green, Pin 16 on Connector 2 (green) as discussed
2002-2001 are 2 connectors, blue and red, Pin 16 on Connector 2 (red)
2000-1999 are 4 connectors, blue, red, clear, black, Pin 23 on Connector 4 (black) as your previous diagrams showed
Before that it looks like Pin 19 on connector 4 on the VCM/PCM but it doesn't specify the connector color
2005 Astro 4x4, 4-5" lift, 31" Tires, np236 Transfer Case, Trans-Go Shift Kit, Hayden Tranny Cooler, Ultragauge MX

racrx7
I finally get the smurf thing
Posts: 134
Joined: Sun Jul 26, 2015 8:25 pm
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Charleston SC

Re: How to wire up a NP 236 in place of a 136.

Post by racrx7 » Wed Jun 14, 2017 10:13 am

curtperry wrote:
racrx7 wrote:If you can find it on ESI that you are downloading, maybe you can share it?
It downloaded after all...

Here's the schematic for a 2005 Blazer with NV236... It appears to have the same connectors on the PCM as we do and again confirms Pin 16 on Connector 2 (Green)
Excellent! Thanks for posting that schematic \:D/ I have it on paper just not on digital
O3 Astro 4X4
Image
Dropped front IFS axle
Journeys rear spring hangers and shackles, S-10 leaf springs, 2" body lift
255/70-16 BFG KO2's on 16x8 Fuel Revolvers

racrx7
I finally get the smurf thing
Posts: 134
Joined: Sun Jul 26, 2015 8:25 pm
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Charleston SC

Re: How to wire up a NP 236 in place of a 136.

Post by racrx7 » Wed Jun 14, 2017 10:18 am

curtperry wrote:I am totally geeking out over this ESI info.

The 4wd Lo signal to the PCM:

2005-2003 are 2 connectors, blue and green, Pin 16 on Connector 2 (green) as discussed
2002-2001 are 2 connectors, blue and red, Pin 16 on Connector 2 (red)
2000-1999 are 4 connectors, blue, red, clear, black, Pin 23 on Connector 4 (black) as your previous diagrams showed
Before that it looks like Pin 19 on connector 4 on the VCM/PCM but it doesn't specify the connector color

Excellent info!! Thanks for adding to this thread :guitar:
The different color connectors from 01-03 are to differentiate a network protocol change, that I understand, and we're carried across all models. :cheers:
O3 Astro 4X4
Image
Dropped front IFS axle
Journeys rear spring hangers and shackles, S-10 leaf springs, 2" body lift
255/70-16 BFG KO2's on 16x8 Fuel Revolvers

trip_south
I am smitten with my van
Posts: 28
Joined: Thu Jan 14, 2016 4:10 am
antispam: No
How many wheels are on an Astro van? (4): 4

Re: How to wire up a NP 236 in place of a 136.

Post by trip_south » Mon Jul 03, 2017 4:53 am

Hm, can you translate what this PCM/VCM connection is all about? Should there be a wire going from the TCCM to somewhere other than the encoder motor/switch?
99 Safari AWD -> 4WD slowly Update: Auto 4wd, 2Hi, 4Hi work, no luck with shifting to 4lo

RINNY
I get chills without my van.
Posts: 100
Joined: Sun Mar 22, 2015 1:58 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: How to wire up a NP 236 in place of a 136.

Post by RINNY » Mon Jul 03, 2017 9:53 pm

curtperry wrote:
racrx7 wrote:If you can find it on ESI that you are downloading, maybe you can share it?
It downloaded after all...

Here's the schematic for a 2005 Blazer with NV236... It appears to have the same connectors on the PCM as we do and again confirms Pin 16 on Connector 2 (Green)
Could this be why my 236 is stuck in 4L and will not shift? When you push any other button it flashed and does nothing and the 4L light stays lit. It is def in 4L I just took it down the driveway after firing up th 5.7L I just installed.

trip_south
I am smitten with my van
Posts: 28
Joined: Thu Jan 14, 2016 4:10 am
antispam: No
How many wheels are on an Astro van? (4): 4

Re: How to wire up a NP 236 in place of a 136.

Post by trip_south » Wed Jul 12, 2017 5:50 am

I had a similar problem and ended up swapping out the encoder motor. To swap in the new, JY one I had to shift the transfer case to neutral manually - this allowed the positions on the tcase and motor to match up. That new motor didn't really work out well and ended up giving me some codes to hunt down, like C0323. Troubleshooting (mainly just checking resistances and voltages at the case/motor) seemed to indicate a faulty encoder motor again. So I ponied up for a new refurbished one from A-1 Cardone. This is in right now and has allowed me to shift between 2HI and 4HI and AWD no problem. 4LO now eludes me.
When you put in your TCCM and connected everything up did you clear the codes using a scan tool? That refresh was necessary to get mine to it's current half working state.
You can remove the encoder motor and try to manually shift it to determine if there's an internal binding issue.

I don't really know about the VCM connection and whether it has a hand in shifting modes. From the last couple pages of the thread it seems like racrx7 was able to get his working fine without making a connection to the VCM. Not sure how you do the wiring between the TCCM and the VCM - isn't the VCM under the hood?
99 Safari AWD -> 4WD slowly Update: Auto 4wd, 2Hi, 4Hi work, no luck with shifting to 4lo

RINNY
I get chills without my van.
Posts: 100
Joined: Sun Mar 22, 2015 1:58 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: How to wire up a NP 236 in place of a 136.

Post by RINNY » Thu Jul 13, 2017 10:38 pm

My encoder motor was frozen solid. It was new too. Got a replacement coming from amazon for no charge, it will be here tomorrow or Saturday. Had one of my newly run wires check out with no continuity, brand new run and it had a break in it, geesh. Also had a new wire pull out of the pin on the orange tccm connector, that's what you get for using the crimper made for those pins (garbage), only did 3 wires with them and I thought I redid all of the 3 with needle nose, guess I missed that one?? Moving forward, we will see what shakes out with the new encoder motor??

trip_south
I am smitten with my van
Posts: 28
Joined: Thu Jan 14, 2016 4:10 am
antispam: No
How many wheels are on an Astro van? (4): 4

Re: How to wire up a NP 236 in place of a 136.

Post by trip_south » Fri Jul 14, 2017 5:19 am

Good luck with the new encoder motor. I don't know if those are really that prone to failure...from reading through the S10/Blazer forums the main issue with the NP 236 seems to be with the vacuum actuator for engaging the front axle, and obviously that's not a thing for Astros (unless you go that route).

I ended up cutting off the wires from the TCCM connectors and just splicing in - didn't have the necessary tool for repinning but did have plenty of butt splices and a good crimper.

Now it looks like perhaps a connection is needed to the VCM (wherever that is) from the TCCM, which may require adding a pin after all if there's not already a wire in the "4lo" spot to splice into. Any ideas about that?
99 Safari AWD -> 4WD slowly Update: Auto 4wd, 2Hi, 4Hi work, no luck with shifting to 4lo

RINNY
I get chills without my van.
Posts: 100
Joined: Sun Mar 22, 2015 1:58 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: How to wire up a NP 236 in place of a 136.

Post by RINNY » Fri Jul 14, 2017 10:57 am

Have not gotten that far as of yet. I have a 2003 so it might be different. I wired the tccm and switch just as he said to. I believe there is a wire coming from the fuse box already on my set up. I will let you know. I wired the relay (to fool the TCCM into thinking there is a front axel actuator) into a relay block I cut out of a parts van so if it goes I can just plug another one in.

RINNY
I get chills without my van.
Posts: 100
Joined: Sun Mar 22, 2015 1:58 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: How to wire up a NP 236 in place of a 136.

Post by RINNY » Fri Jul 14, 2017 10:58 am

If his was working before the VCM stuff came up mine should work too, we both have 03's

RINNY
I get chills without my van.
Posts: 100
Joined: Sun Mar 22, 2015 1:58 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: How to wire up a NP 236 in place of a 136.

Post by RINNY » Sun Jul 16, 2017 1:09 am

Well new encoder motor works!! I had a frozen encoder motor, a new run of wire with no continuity so that run got replaced and a wire pulled out of a pin on the orange TCCM connector. I now have 2H, Auto 4WD, 4H, I will know if I have 4L as soon as I can roll the van in neutral (it should engage). Got to straighten out a misfire issue first on the 5.7 that I just put in. Will know soon enough. No VCM wiring involved so far!!

Post Reply