AstroSafariVans.com

The premier site for Astro and Safari van information
It is currently Tue Sep 30, 2014 9:52 pm

All times are UTC




Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: 99 Safari fuel and or electrical problem.
PostPosted: Sun Jun 24, 2012 2:45 pm 
Offline
I am merely driving my van
I am merely driving my van

Joined: Mon Jan 09, 2012 3:55 am
Posts: 14
Hey everyone,
Been reading all the trouble shooting info and have got some good input but need a little more beta if possible.
I have a 99 Safari AWD and need a little help with some trouble shooting. Two issues are going on.
1. it has 130,000 miles and has been running great other than when idling it has a crazy surge. Surges really high and then drops down to normal. Totally rhythmic and constant.

2. This just happened yesterday as I was driving home from a road-trip. The van was running fine, started to bog and then just died. Started right up and would only drive very slow and any push on the gas pedal would cause it to die. Limped it 30 miles (over 2 hrs) to a gas station. Filled the tank up with premium (6 gallons needed to top it off) and added some octane booster. Started right up and made it 100 miles home before the same issue happened again.
I read in a previous post that maybe a new Ignition Control Module and pick up coil would be a good trouble shooting fix.
Any and all info would be great. Thanks so much. Cheer, Atom....
PS, my gas mileage also sucks. 13-14 mpg


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Sun Jun 24, 2012 4:56 pm 
Offline
I am merely driving my van
I am merely driving my van

Joined: Mon Jan 09, 2012 3:55 am
Posts: 14
Just ran the codes
Codes showing up are P0131, P0151, P0327 (is there a place I can find what the codes represent?)
Thanks again, Atom...


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Sun Jun 24, 2012 6:33 pm 
Offline
Site Admin
Site Admin
User avatar

Joined: Sat Sep 09, 2006 10:35 pm
Posts: 4384
Location: New Haven, NY
Just use google (or you favorite search engine) to look the codes up. P0131 and P0151 are oxygen sensor codes and P0327 is a knock sensor code. The symptoms you describe shows it is probably the knock sensor.

_________________
Current rides:
2013 Toyota Tundra DC 4x4
2008 Dodge Nitro 4x4
2005 Nissan Sentra 1.8S Special Edition

Mileage spreadsheet

Vans owned:
1986 Safari 2.5L 4 speed manual - scrapped
1995 Astro 2WD conversion 4.11 posi, shift kit, DHC rock rails - sold to Skippy
1998 Astro 4x4 D44, D60, NP231, full hydraulic system with 9k# Milemarker winch and snow plow - sold to Lockdoc
2003 Astro AWD all stock - traded for a 3/4 ton truck
2005 AWD, 4.10's - sold to skippy


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Sun Jun 24, 2012 11:34 pm 
Offline
I am merely driving my van
I am merely driving my van

Joined: Mon Jan 09, 2012 3:55 am
Posts: 14
Thanks for the info. Going to the auto store in the am. Appreciate your help. Atom....

LiftedAWDAstro wrote:
Just use google (or you favorite search engine) to look the codes up. P0131 and P0151 are oxygen sensor codes and P0327 is a knock sensor code. The symptoms you describe shows it is probably the knock sensor.


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Wed Jun 27, 2012 8:11 pm 
Offline
I am merely driving my van
I am merely driving my van

Joined: Mon Jan 09, 2012 3:55 am
Posts: 14
I must be an idiot :rolleyes: I can't find the Knock sensor on my van. The manual says near the Distributor? No luck at all. Any ideas?

LiftedAWDAstro wrote:
Just use google (or you favorite search engine) to look the codes up. P0131 and P0151 are oxygen sensor codes and P0327 is a knock sensor code. The symptoms you describe shows it is probably the knock sensor.


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Thu Jun 28, 2012 8:13 am 
Offline
ASV Supporter
ASV Supporter
User avatar

Joined: Fri Aug 08, 2008 7:55 pm
Posts: 2633
Location: Vancouver, BC, Canada
at left rear of distributor, on engine block


Attachments:
lreng.png
lreng.png [ 110.57 KiB | Viewed 591 times ]
Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Thu Jun 28, 2012 5:53 pm 
Offline
I am merely driving my van
I am merely driving my van

Joined: Mon Jan 09, 2012 3:55 am
Posts: 14
Thanks, under my very nose. Could have sworn I looked for hours in that very place. Time to take that darn cover off again. Thanks again :cheers: Atom...

timelessbeing wrote:
at left rear of distributor, on engine block


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Thu Jul 19, 2012 8:45 pm 
Offline
I am merely driving my van
I am merely driving my van

Joined: Mon Jan 09, 2012 3:55 am
Posts: 14
Having major problems with this. So I bought the new knock sensor. Brass looking round item with threads coming out the bottom and a plastic piece on top where a single wire attaches. Looks just like every pic I have seen of a KS. The place that this is supposed to mount according to the manual and the photo you posted has a different part there.
I pulled the part. It has a long screw going through the black round plastic body. Coming off the side of the round plastic piece is the female end that the wiring attaches to. The threads of the screw are way smaller than the threads of the Knock sensor that I purchased. So the new KS would not fit in there anyway.
I am at a total loss. Any ideas? 1999 GMC Safari AWD 4.3L Vortec engine.... [-o<



timelessbeing wrote:
at left rear of distributor, on engine block


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Thu Jul 19, 2012 9:22 pm 
Offline
ASV Supporter
ASV Supporter
User avatar

Joined: Fri Aug 08, 2008 7:55 pm
Posts: 2633
Location: Vancouver, BC, Canada
:-k Some photos would help big time.


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Thu Jul 19, 2012 9:53 pm 
Offline
I am merely driving my van
I am merely driving my van

Joined: Mon Jan 09, 2012 3:55 am
Posts: 14
Not that great a photo but it is the bolt with the little green dot on top. That is where everything says the knock sensor should go. To the right is the oil sensor and upper right is distributor. Any ideas? Thanks, Atom...

Image


timelessbeing wrote:
:-k Some photos would help big time.


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Fri Jul 20, 2012 1:47 am 
Offline
ASV Supporter
ASV Supporter
User avatar

Joined: Fri Aug 08, 2008 7:55 pm
Posts: 2633
Location: Vancouver, BC, Canada
That looks a lot like a 2000 knock sensor.

Check the condition of the wires before you put everything back together.


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Tue Jul 24, 2012 8:44 pm 
Offline
I am merely driving my van
I am merely driving my van

Joined: Mon Jan 09, 2012 3:55 am
Posts: 14
I went through all the years after 97 at the auto parts store. This is what the part should look like on all those years. I'm at a total loss.. :cry:
Image


timelessbeing wrote:
That looks a lot like a 2000 knock sensor.

Check the condition of the wires before you put everything back together.


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Wed Jul 25, 2012 6:39 am 
Offline
ASV Supporter
ASV Supporter
User avatar

Joined: Fri Aug 08, 2008 7:55 pm
Posts: 2633
Location: Vancouver, BC, Canada
this is what I came up with

Image


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Wed Jul 25, 2012 12:32 pm 
Offline
I am merely driving my van
I am merely driving my van

Joined: Mon Jan 09, 2012 3:55 am
Posts: 14
That is the part. Is it a knock sensor? I have been to 6 different auto part stores and they don't show that part.

timelessbeing wrote:
this is what I came up with

Image


Top
 Profile  
 
 Post subject: Re: 99 Safari fuel and or electrical problem.
PostPosted: Wed Jul 25, 2012 6:26 pm 
Offline
ASV Supporter
ASV Supporter
User avatar

Joined: Fri Aug 08, 2008 7:55 pm
Posts: 2633
Location: Vancouver, BC, Canada
yup


Attachments:
Screen shot 2012-07-25 at 11.25.21 AM.png
Screen shot 2012-07-25 at 11.25.21 AM.png [ 173.73 KiB | Viewed 520 times ]
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group