AstroSafariVans.com

The premier site for Astro and Safari van information
It is currently Mon Aug 21, 2017 8:14 am

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Misfire - P0303 Code - Did the basics. what next?
PostPosted: Sun Aug 13, 2017 12:46 am 
Offline
I am merely driving my van
I am merely driving my van

Joined: Mon Sep 14, 2015 2:52 pm
Posts: 4
So I have a '04 Astro AWD with about 110k miles on it. I've owned it for ~2 years or so, and it has never gotten very good gas mileage - typically about 14mpg and has always had a rough idle.

A few weeks ago, I was driving it and the check engine light started flashing and the engine began running very rough. I had Autozone try to pull a code, but there was no code set. I went on vacation, bought a code reader, came back, and there was a P0303 code on start up.

I've pulled the #3 cylinder spark plug, it was dark and sooty. I replaced it with a new plug and installed a new plug wire. Tested spark and the spark strength looks the same on the #1 and #3 cylinders. Fired up the van, cleared the code, and it came right back after a few minutes.

I did a compression check on Cylinders 1 and 3, and I've got about 150 psi in both. I don't think compression is the issue but I'll check some cylinders on the other bank to see what they look like.

I was using the code reader to monitor the fuel trims while idling and then at 2500 rpm. I don't really know what I'm looking for, but the Bank 1 short term fuel trim seems to oscillate a great deal at idle, and can range from 0 to -30%, which seems extreme. The Bank 2 short term fuel trim also oscillates a good bit, but is usually quite a bit closer to zero than the Bank 1 trim.

However, I don't know if I trust the reader, as the long term fuel trim seems to change way too fast. The short term trim also fluctuate pretty quickly, and will occasionally just reset to 0%.

Here are the ranges I'm seeing for the following parameters at idle and at 2500 RPM
700 RPM / 2500 RPM
Engine Coolant: 195 deg F / 204 deg F
Shirt Term Fuel trim bank 1: -2.3% / -13.3%
Long Term Fuel trim bank 1: -14.1% / 10.9% (how did this change so much in just a few minutes of engine operation?)
Short Term Fuel trim bank 2: -2.3% / 7.0%
Long Term Fuel trim bank 2: -16.4% / -3.1%
Intake Manifold Pressure: 11.4 inHg / 9.6 inHg
TIming advance for #1 cylinder: 17.5 deg / 42 deg (does 42 degrees of timing advance seem odd?)
Intake Air Temp: 111 deg F / 109 deg F (It was hot out)
Air flow rate from mass air flow sensor: 0.9 lb/min / 3.2 lb/min
O2 Sensor Bank 1 Sensor 1: 0.58V / 0.710 V
O2 Sensor Bank 1 Sensor 2: 0.57V / 0.85 V
O2 Sensor Bank 2 Sensor 1: 0.735V / 0.065 to 0.825 V (The 2500 RPM reading seems off)

Can anyone give me some idea of what ranges are typical for these parameters? I have no idea.

It seems like it is probably an injector on the #3 cylinder. I would think that an O2 sensor would lead to problems with the whole bank, while a distributor gear would lead to a random misfire condition.

Is there anything I can do to verify before I crack open the intake and replace the spider? Any other diagnostics I should do?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group