AstroSafariVans.com

The premier site for Astro and Safari van information
It is currently Wed Apr 23, 2014 6:02 pm

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: help please shudder? issue
PostPosted: Fri Jun 11, 2010 5:21 am 
Offline
I am smitten with my van

Joined: Fri Jun 11, 2010 2:03 am
Posts: 30
I just bought a 1998 safari awd with 152k I had the knock sensor replaced and I was told by the shop that replaced the sensor that they "checked everything else out" and think my problem is a drive train issue The van runs fine and shifts smooth with no issues The problem is, from the speed of about 40 miles per hour it starts to shudder (I think as it doesn't hesitate or sputter) very very very badly The shudder is accompanied by a loss of power or a feeling of driving in sand To the point of feeling like it's going to break down If I floor it and it down shifts or let off the gas the shudder stops This only happens when the van is warm When its cold it does not shudder or show any signs of the problem The trans fluid looks new but I have not had the drain pan off or looked in the transfer case There is a significant leak in the vacinity of the power steering pump weather a line or trans or steering fluid I dont know (I have read in the forums that the trans lines can get clogged) my other safari runs at about 1 tick below 210* on the temp gauge while the one with the problem runs 4 or more ticks below 210* on the temp gauge the heat works fine and I don't think the thermostat is the problem Should I change the trans and transfer fluid or should I go to a trans shop and bend over? Any help would be hugely appreciated thanks in advance


Top
 Profile  
 
 Post subject: Re: help please shudder? issue
PostPosted: Fri Jun 11, 2010 10:32 am 
Offline
Site Admin
Site Admin
User avatar

Joined: Sat Sep 09, 2006 10:35 pm
Posts: 4312
Location: New Haven, NY
Welcome!

Do a tune-up first thing. New GM cap, rotor and plugs and wires. Do an air filter as well as fuel filter. After that you can pull the trans pan and change the filter and add fresh fluid. Do not do a flush as this may dislodge any particles and kill the tranny. I will bet the tune-up will get rid of the hesitation. When it hesitates, pull the lever down into 3rd and maintain speed. I bet it clears up mostly if not 100%.

_________________
Current rides:
2013 Toyota Tundra DC 4x4
2008 Dodge Nitro 4x4
2005 Nissan Sentra 1.8S Special Edition

Mileage spreadsheet

Vans owned:
1986 Safari 2.5L 4 speed manual - scrapped
1995 Astro 2WD conversion 4.11 posi, shift kit, DHC rock rails - sold to Skippy
1998 Astro 4x4 D44, D60, NP231, full hydraulic system with 9k# Milemarker winch and snow plow - sold to Lockdoc
2003 Astro AWD all stock - traded for a 3/4 ton truck
2005 AWD, 4.10's - sold to skippy


Top
 Profile  
 
 Post subject: Re: help please shudder? issue
PostPosted: Fri Jun 11, 2010 11:24 am 
Offline
I sleep in my van
User avatar

Joined: Mon Sep 29, 2008 3:35 pm
Posts: 692
Location: Victoria B.C.
It's my guess that your tranny is definitely on it's way out. The previous owner "may" have replaced the fluid so as it would look "OK" for selling it, but in a short time it will begin to smell burnt and start to change colour.
A free estimate at any tranny shop should be able to tell you more.

Peter


Top
 Profile  
 
 Post subject: Re: help please shudder? issue
PostPosted: Fri Jun 11, 2010 3:47 pm 
Offline
I am smitten with my van

Joined: Fri Jun 11, 2010 2:03 am
Posts: 30
OK here is an update--------- I took it to a reputable trans shop and the only code they pulled was for the knock sensor which the shop I took it to supposedly changed yesterday so I will bring it take back to the shop asap as I am into them for $160 for supposedly changing the knock sensor already Any thoughts? maybe a short? I saw a bad splice by the camshaft position sensor that I told the shop about The reason I didn't check and change the sensor myself was because if there was a wiring issue I thought they could figure it out Anybody know of a reputable shop in the Portland OR area? Again the van shudders badly under power from about 40mph on only when its warmed up and I have a knock sensor code


Top
 Profile  
 
 Post subject: Re: shudder problem?
PostPosted: Fri Jun 11, 2010 11:21 pm 
Offline
I am smitten with my van

Joined: Fri Jun 11, 2010 2:03 am
Posts: 30
shop just called to tell me that the engine is a 2002 in a 1998 and that the computer is not wired in properly or wrong computer being that I keep throwing a knock sensor code is possible that it is just isolated to that ? this thing is gonna bank rupt me


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group