Speedometer No longer works HELP

IF YOU HAVE QUESTIONS OR ISSUES WITH ANYTHING RELATED TO OBD-1 AND OBD-2, SECURITY, AUDIO AND VIDEO SYSTEMS, PLACE THEM HERE. USE THIS FORUM FOR SES LIGHTS, RPO CODES, FACTORY OPTIONS ETC.

Moderator: v8famvan

User avatar
meetthespeakers
I sleep in my van
Posts: 334
Joined: Tue Nov 06, 2007 8:01 pm
How many wheels are on an Astro van? (4): 6
Location: Vienna, VA
Contact:

Speedometer No longer works HELP

Post by meetthespeakers » Fri Apr 03, 2009 3:55 pm

2 nights ago the speedometer stopped working on my way home. All the other gauges work fine. I thought, okay easy enought, just replace the speedo cable.... but these vans don't have that do they? Is this an easy fix, and what part am I looking for? I have a 1998 AWD Astro. Thanks, I hope its a quickie job... please please please.
Image
1993 Astro, 1973 Austin Mini Clubman Estate, 1980 Trabant, 1961 Morris Minor

User avatar
Jinmajay
I sleep in my van
Posts: 294
Joined: Mon Jan 07, 2008 12:40 pm
How many wheels are on an Astro van? (4): 6
Location: Columbia, MO
Contact:

Re: Speedometer No longer works HELP

Post by Jinmajay » Fri Apr 03, 2009 9:01 pm

No cable just VSS (vehicle speeed sensor). It is located on the rear of the Tranny. It could be the gauge itself or connector. Have you lost any of the other gauges (fuse)? If the VSS went bad then you would have other drivability issues too.
The Tran man http://jayjensen.shutterfly.com/action/

1994 AWD GMC Safari, V8 truck van project
1998 2WD Astro
1999 AWD Astro

User avatar
meetthespeakers
I sleep in my van
Posts: 334
Joined: Tue Nov 06, 2007 8:01 pm
How many wheels are on an Astro van? (4): 6
Location: Vienna, VA
Contact:

Re: Speedometer No longer works HELP

Post by meetthespeakers » Tue Apr 07, 2009 4:37 pm

I ordered a new vss sensor for on the tranny. Took me a while to find a place that could order it. 2 days after the speedo stopped working the abs light came on. The brakes are funky now. Also the engine rev's higher now as well. I hope all of it is related because it all happened at the same time. Hopefully it is just a simple swap?
Image
1993 Astro, 1973 Austin Mini Clubman Estate, 1980 Trabant, 1961 Morris Minor

User avatar
Jinmajay
I sleep in my van
Posts: 294
Joined: Mon Jan 07, 2008 12:40 pm
How many wheels are on an Astro van? (4): 6
Location: Columbia, MO
Contact:

Re: Speedometer No longer works HELP

Post by Jinmajay » Wed Apr 08, 2009 11:46 am

That's the problem I'm sure because of all the other related stuff.
Go to Autozone and register. Then go to the repair guide. It should be straight forward repair. \:D/
The Tran man http://jayjensen.shutterfly.com/action/

1994 AWD GMC Safari, V8 truck van project
1998 2WD Astro
1999 AWD Astro

robertg
I finally get the smurf thing
Posts: 118
Joined: Sat Sep 23, 2006 11:52 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: cortland, ohio

Re: Speedometer No longer works HELP

Post by robertg » Tue Apr 14, 2009 3:43 am

my cluster went out a couple of weeks ago, and i'm saving $$$ aside for a new one.

i currently have only oil pressure and voltmeter, the ses light, and my turn signal telltales. i narrowed it down to the cluster by verifying that i had a vss reading with the scan tool, and my cruise control still works.

the other lights coming on leads me to suspect the vss since the vehicle needs a speed signal for abs or cruise, etc.

speaking of which... if it's equipped, does your cruise control work? that's a good tip-off that your vss isn't working.

let us know! :)
2000 Astro 4.3 A4- b&m transcooler/autometer trans temp gauge. 171k miles
1995 Astro 4.3 A4- generic flowmaster muffler. 239k miles

User avatar
meetthespeakers
I sleep in my van
Posts: 334
Joined: Tue Nov 06, 2007 8:01 pm
How many wheels are on an Astro van? (4): 6
Location: Vienna, VA
Contact:

Re: Speedometer No longer works HELP

Post by meetthespeakers » Tue Apr 14, 2009 2:31 pm

Normally 99% of the time it is the VSS. What I learned and posted in my other thread it was much more serious. My fuel injectors are leaking. They in turn leaked through the PCM harness and into the PCM. So currently I am waiting for my new fuel injector setup and re-programmed PCM. I wish it were as simple as the VSS. Hopefully once I get this sorted I will be on my way again. Cheers.
Image
1993 Astro, 1973 Austin Mini Clubman Estate, 1980 Trabant, 1961 Morris Minor

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Tue Jul 03, 2012 5:17 am

I have a very similar problem. I am suspecting the vss as well. My speedo, odo, fuel & temp guages sometimes do not work. It also will only move in 2nd and 3rd gears. I have to manually shift it when this happens. The problem comes and goes. I am not getting a vss code with the scan tool, only sensor codes for the left and right front ABS sensors. Please let us know what you do to resolve this problem. I'd love to stop hanging parts on my van!

Thanks & good luck!
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Fri Mar 15, 2019 11:13 pm

It has been a long while and I apologize for not getting back to you all. Life gets in the way of life, sometimes. The repair for this trouble that i had encountered was to replace the ignition switch harness in the steering column. This cured all of my woes. The harness controls (+5 volts?) the voltage to the VSS and solenoid if I remember correctly. This 2000 Safari has since gone to a new home, but my current 2004 LS Astro AWD is experiencing similar troubles. I am ordering a new harness ($55 shipped) tonight and well see what happens. I will post regardless of this correcting my current trouble. Thanks and good luck to us all!
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Sun Mar 17, 2019 8:24 pm

So, installed a VSS (transmission) and no change. Jiggled the wires (cannot remember which ones supply the 5 volts to the trans ... maybe pink? white?) and suddenly everything works. I originally had an ABS, brake, and check engine lights on. These were all also off. Yay! Until....I used my turn signal. All idiot lights came back on. Speedo, Odo, and trans still work though. I now firmly believe this is also an ignition switch harness trouble. I hope it arrives soon.
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Sun Apr 21, 2019 3:04 am

Here's an update. New wiring harness for the ignition switch. Van drove well for about 2 hours. Then....erratic speedo and funny shifting between 3rd & 4th. Different troubles than before. Also, it had developed a mystery squeak. This occurred at a low RPM and only in forward gear to begin. Just when taking off from the driveway or at a light. Low RPM, with a load. It progressed to reverse and in all gears with a heavy load. I assumed it was a belt or pulley. 240,000 miles seemed like time for maintenance. New idler, belt, water pump, fan clutch and the sound persists. I have read of many similar mystery squeaks on the Silverado lineup. I truly hope this is not part of my shifting troubles. This squeak is present with no vehicle movement if I stomp on the throttle. It's not the in u-joints or front & rear diff. Found a wire with burnt insulation on the driver's side of the engine nearest the firewall. Re-wrapped it. The mess of wires on the transfer case seems to be brittle. Not sure what to do there. I think i replaced the incorrect sensor on the transfer case. I think it was the output sensor and not the VSS. Passenger side sensor on my AWD transfer case. Any suggestions? Irregular speedo and shifting, specifically after warm up. I will be replacing the sensor on the driver's side rear on Easter morning. (SUCKS!)
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

User avatar
timelessbeing
Site Admin
Site Admin
Posts: 2715
Joined: Fri Aug 08, 2008 7:55 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: Speedometer No longer works HELP

Post by timelessbeing » Sun Apr 21, 2019 3:59 am

risteff wrote:This squeak is present with no vehicle movement if I stomp on the throttle.
So you're saying it squeaks even when then wheel's aren't turning?
Suspension... engine mounts...
leaf springs tend to squeak and getting on the throttle flexes them. GM actually suggests putting some grease between them on a lot of trucks and vans.

Here's a part breakdown of a NV136

http://tcase.rsgear.com/technical/diagr ... -case.aspx

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Sun Apr 21, 2019 1:51 pm

Interesting. I'll see what I can find. I appreciate the breakdown. Yes, it will sqeak (under a load = WOT rev from idle) with the wheels not moving. The squeak seems to be coming from the lower side of the engine or transmission. I cannot locate it. It generally lessens or goes away after a good warm up of 20 minutes or so of driving. I have not investigated the motor mounts ... yet. Maybe... Thank you for your help. Happy Easter.
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Sun Apr 21, 2019 3:18 pm

I was correct. I had replaced the incorrect sensor. I replaced the driver's side rear sensor (VSS) this morning. Short test drive = ABS light turned off. BRAKE light turned off. SES light came on. Everything seemed to operate as it should. after less than 3 minutes, the ABS and BRAKE lights both turned back on. Vehicle is still cold. I will drive it shortly and see how it performs after it's warmed up. Am I correct in assuming that the transmission itself does NOT have a bolt in VSS since this van is an AWD and the T-case takes the place of the 4L60E tailshaft housing? I also took a short video with sound of my squeak. Not sure how to post it though.
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

User avatar
timelessbeing
Site Admin
Site Admin
Posts: 2715
Joined: Fri Aug 08, 2008 7:55 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: Speedometer No longer works HELP

Post by timelessbeing » Sun Apr 21, 2019 6:22 pm

Time to scan the trouble codes.

Upload your video to youtube and then post the link.

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Sun Apr 21, 2019 11:01 pm

Well....not my upload, but seems to have all of the same codes. https://www.youtube.com/watch?v=7mMHy5QrOfo
C0242
C0281
C0237
C0236
C0265
C0227
C0225
C0245
C0241
C0251
C0252
C0246
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

Post Reply