Speedometer No longer works HELP

IF YOU HAVE QUESTIONS OR ISSUES WITH ANYTHING RELATED TO OBD-1 AND OBD-2, SECURITY, AUDIO AND VIDEO SYSTEMS, PLACE THEM HERE. USE THIS FORUM FOR SES LIGHTS, RPO CODES, FACTORY OPTIONS ETC.

Moderator: v8famvan

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Sun Apr 21, 2019 11:08 pm

Cleared my codes and went for a drive. 1st gear only in D. I can manually shift into 2nd. If I return it to D, the trans has no gear. Absolutely no speedometer now. Re-read codes and get only C0265 which is an EBCM "No signal".
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

User avatar
timelessbeing
Site Admin
Site Admin
Posts: 2710
Joined: Fri Aug 08, 2008 7:55 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: Speedometer No longer works HELP

Post by timelessbeing » Sun Apr 21, 2019 11:38 pm

I always check the obvious stuff first. Make sure the EBCM plug makes a good connection. Make sure it's getting good power and ground. Is your electrical system healthy (ie battery + alternator).

Then I would do the same for a transmission. (I can't remember if it's controlled by the PCM or if there's a separate module for it).

electrical schematics:
http://www.bbbind.com/tsb-wiring-diagrams-database/

More diagrams and component locators:
https://www.gmupfitter.com/pages/body-builder-manuals

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Mon Apr 22, 2019 2:02 am

Thank you timlessbeing. I certainly appreciate your support and help! I tried to review as much as I could while under my van (I love my van). I found a Bank 1 Sensor 1 (front driver's side) O2 sensor with two wires rubbed through. I separated and insulated them. I found the source of a gasoline smell I've been trying to find for months (fuel filter). I placed the original VSS back into the T-case and went for another short drive. Speedometer at 100 but the trans shifted through all gears fine. Speedometer reset itself. ABS and SES lights still on. Another code read still shows C0265 and a Bank 1 Sensor 1 O2 Sensor fault. I'm tired and need to go to bed. I will investigate more tomorrow evening if I can. I would like to try to locate the ground wire for the EBCM.
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Mon Apr 22, 2019 2:07 am

Wow! Thank you timelessbeing for the links. This is some really good information! I most certainly appreciate it!
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Wed Apr 24, 2019 1:06 am

Sooo.....after repairing the exposed wires on the bank 1 sensor 1 O2 sensor, I took it for a drive. It seemed to work fairly well, but had trouble from 1st to 2nd gear. Drive it quite a bit. WOT to shift or very light throttle would also make it shift. That tells me the throttle position has an impact. Took it home and scanned again. Still getting a C0265 = EBCM Motor Relay Circuit code. Also getting a C0237 Throttle Position Signal Malfunction. Making progress. I'll try to get the TPS changed in the next few days and report back. I'll also be replacing the O2 sensor.
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

Astrophysics
I sleep in my van
Posts: 823
Joined: Sun Jan 13, 2008 5:23 am
antispam: No
How many wheels are on an Astro van? (4): 4

Re: Speedometer No longer works HELP

Post by Astrophysics » Wed Apr 24, 2019 1:54 am

Hi,

Excellent work troubleshooting this issue!

Thank you for sharing the results.

My 2003 AWD has 133,000 miles.

I hope not to have similar issues for many more years. But, I will know about wiring issues.

AP

User avatar
timelessbeing
Site Admin
Site Admin
Posts: 2710
Joined: Fri Aug 08, 2008 7:55 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: Speedometer No longer works HELP

Post by timelessbeing » Wed Apr 24, 2019 6:06 am

Here are some TPS diagnostics ...

- - - - - -
Symptoms of a Defective TPS

The 'Check Engine' Light is On
Bucking and Jerking/Hesitation while Accelerating
Idle Surging
Sudden Stalling of the Engine
Sudden Surge in Speed While Driving on the Highway

Testing
Test between blue and black wire.
.5v idle to 5v WOT
the readings should gradualy change hitting no dead spots



Or you can test with a ohms meter
TPS Actuator Arm at rest: Pins Values (ohms)
A to C = 5.88k
A to B = 2.44k
C to B = 8.32k

Rotating the TPS Actuator Arm: At Rest Rotated
A to B = 2.44k 8.26k
C to B = 8.32k 2.39k
Attachments
TPStest_zpsd84d741f.PNG

User avatar
timelessbeing
Site Admin
Site Admin
Posts: 2710
Joined: Fri Aug 08, 2008 7:55 pm
antispam: No
How many wheels are on an Astro van? (4): 4

Re: Speedometer No longer works HELP

Post by timelessbeing » Wed Apr 24, 2019 6:07 am

... and O2
(typos are not mine =; )


- - - - -

Symptoms of a Defective Oxygen Sensor
Poor fuel economy
Higher emissions
Stalling-Hesitation

Test
0.0 volts = Lean
1.0 volts = Rich

O2 sensor reading at the ECM to .450-.500mv when in open loop or the connector is disconnected.
ground the diagnostic connector and rev engine to 2000 rpm . The Check Engine light should flash once per second for closed loop operation and once every 1/2 second for open loop. It should start out in open loop and then change to closed loop and stay there.
If it flashes closed loop operation and then switches back to open loop operation for a few seconds. Check the O2 circuit for grounding out or poor connection. If that is OK then replace the o2 sensor.
if your getting a lean code this could point to a bad ground or poor conection

Knock sensor test
Parts store

the knock sensor produces its own electric currant. its very small but you can test for it. Set you tester to A/C probe the center of the sensor with the red lead and ground the black lead. now tap on the sensor it will produce 6-12 K hz

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Mon Apr 29, 2019 12:26 am

I have been out since my last post. I hurt myself and ended up in the ER and light duty for a couple of weeks. No further advancement on my Astro van. I will further diagnose it and update you guys during the week (I hope). I have yet to upload the squeak video to youtube. It's strange. The motor mounts and everything looks to be in good condition. I even let it idle with the brake on while I got under it (not in a position to be run over) and couldn't locate the squeak. It's puzzling.
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

risteff
I get chills without my van.
Posts: 87
Joined: Mon May 10, 2010 5:26 am
antispam: No
How many wheels are on an Astro van? (4): 4
Location: Dayton Ohio ish

Re: Speedometer No longer works HELP

Post by risteff » Sun Aug 11, 2019 9:32 pm

Wow! What a year so far. Wanted to update on my 04 Astro's status. Status is---the same. After I hurt my arm, we had area tornados Memorial Day weekend. Noting major. End of June, lost a very large tree. July, Car accident (not the Astro), and daily driver broken (again, not the Astro). Finally Starting to get back on it this week. Things have finally started to settle here (I hope). My first focus is the EBCM. I have had plenty of time to think about this one. We'll see what happens and I will update everyone with my efforts, results, and repairs for future group support.
Past vans: 1990 2WD SLE Safari, 1990 AWD SLE Safari. Current 2000 AWD Safari SLE, and 2004 Astro AWD.

Captn. Crunch
Site Admin
Site Admin
Posts: 508
Joined: Wed Feb 01, 2012 8:10 pm
antispam: No
How many wheels are on an Astro van? (4): 4
Location: southeastern ct

Re: Speedometer No longer works HELP

Post by Captn. Crunch » Sun Aug 11, 2019 10:08 pm

Yikes ! Troubles are only supposed to come in three’s!!
Welcome back
Captn. Crunch
"I don't beat my rig-I use it to it's maximum potential"
1994 Safari conversion (sold) and miss'n it!
1999 Safari SLE AWD junked
2003 GMC Safari AWD SLT
cast iron Torsen equipped front diff
S-10 leafs-G80 rear w/3.73’s
2” body lift w/Falken Wildpeak AT’s

Post Reply